読者です 読者をやめる 読者になる 読者になる

YOwatari's blog

思うままに。

ruby 1.8.7-p249 がビルドできなくて困った

tl;dr

openssl のバージョンとの差で 1.8.7-p249 がビルドできないマンになったので、パッチを当ててインストールした

パッチ

ruby-openssl-1.0.0.patch · GitHubUbuntu 13.10にruby 1.9.2をインストールする時にSSLv2のエラーが出たら - Qiita を使えばビルドできる

単純にくっつけたパッチ ruby-1.8.7-p249.patch.diff · GitHub

ビルド

GitHub - rbenv/ruby-build: Compile and install Ruby の通りにやればモーマンタイ

$ rbenv install --patch 1.8.7-p249 < <(curl -sSL https://git.io/ruby-1.8.7-p249-patch)

余談

gist の raw なリンクは長くてつらいので git.io を使うと便利。指定の名前にしたい時は↓を参考に。

qiita.com